Wingtask not installing

The install.sh script freezes on this part

I tried to manually install and did all the steps, but when i try to sync. This happens

Tail of .taskrc

.wingtask_certs folder
image

Looking at the screenshots what jumps out is that the install script froze while trying to configure your .taskrc file. The install script executes this command:

task config "taskd.server" "app.wingtask.com:53589"

if this command hangs that leads me to wonder if there is something weird going on with your Taskwarrior installation.

Here’s what you should try:

Reset your .taskrc file back to original. There was a copy of your .taskrc file made by the install script.

cp ~/.taskrc.orig ~/.taskrc

Run task diagnostics and see if anything unsual comes up, go ahead and paste a screenshot or write it to a file and upload here.

task diagnostics

write it to file

task diagnostics > output

You could try also trying to configure the .taskrc

task config var foo

and see if that runs.

IMPORTANT!!!

The screenshot above includes your taskd.credentials, (the line that read taskd.credentials=…). That account is now considered compromised, and I went ahead and deleted this account. What you should do now is to create a new account. You’ll need to then download the configuration for the new account and retry all the steps above.

Let me know how it goes.

I returned the .taskrc file to original and it did not work

Output of task diagnostics:

task 2.5.0
Platform: Linux

Compiler
Version: 5.3.1 20160216
Caps: +stdc +stdc_hosted +LP64 +c8 +i32 +l64 +vp64 +time_t64
Compliance: C++11

Build Features
CMake: 3.2.2
libuuid: libuuid + uuid_unparse_lower
libgnutls: 3.4.9
Build type: None

Configuration
File: /home/renan/.taskrc (found), 1379 bytes, mode 100664
Data: /home/renan/.task (found), dir, mode 40755
Locking: Enabled
GC: Enabled
Server:
Trust: strict
Certificate: , not readable, 0 bytes
Key: , not readable, 0 bytes
Ciphers: NORMAL
Creds:

Hooks
Scripts: Enabled
(-none-)

Tests
$TERM: xterm (167x41)
Dups: Scanned 0 tasks for duplicate UUIDs:
No duplicates found

A suggestion I have first is to try upgrading Taskwarrior from 2.5.0 to 2.5.1.

https://taskwarrior.org/download/

Next go ahead and create a new account (I went through and cleared out the issues you had with this)

Download the WingTask configuration from the new account and try running the install script again.

If you run into any issues try running taskwarrior commands with the debug config:

task rc.debug=1 rc.debug.tls=2 sync init

Screenshot the output and put it here and we’ll try to see what’s going on.

It’s possible the install script is not compatible with Taskwarrior 2.5.0 and I’ll need to rewrite it to be backwards compatible. I’m not sure though.

Reading through the history of this issue, I’m thinking we can get the sync going by doing a manual install.

  1. Download WingTask configuration for your new WingTask account.

  2. Let’s clear out the previous certs if they exist
    rm -rf $HOME/.wingtask_certs

  3. Copy wingtask_configuration/wingtask_certs from where you downloaded it, to a hidden directory in $HOME,
    cp -r wingtask_configuration/wingtask_certs $HOME/.wingtask_certs

  4. Open the example taskrc in wingtask_configuration and copy and paste the WingTask configuration block into your $HOME/.taskrc it should look like this:

    # WingTask sync server
    taskd.server=app.wingtask.com:53589 taskd.key=$HOME/.wingtask_certs/tim@wingtask.com.key.pem taskd.ca=$HOME/.wingtask_certs/dst.pem taskd.certificate=$HOME/.wingtask_certs/tim@wingtask.com.cert.pem taskd.credentials=WingTask/tim@wingtask.com/xxxxxxx-xxxx-xxxxx-xxxx-xxxxxxxxxx

  5. Run task diagnostics to verify your configuration:
    task diagnostics

You should see a block of diagnostics that look like this:

Server: app.wingtask.com:53589
CA: /home/renan/.wingtask_certs/dst.pem, readable, 2260 bytes
Trust: strict
Certificate: /home/renan/.wingtask_certs/renancunhafonseca@gmail.com.cert.pem, readable, 3704 bytes
Key: /home/renan/.wingtask_certs/renancunhafonseca@gmail.com.key.pem, readable, 24745 bytes
Ciphers: NORMAL
Creds: WingTask/renancunhafonseca@gmail.com/************************************
  1. If your diagnostics results don’t match closely then you can stop. Check and verify your paths are correct and also that you have permissions to read all of the files listed above. If it looks good go ahead and run task sync init

The point of this was to make sure that at least your configuration is setup correctly. If you still have problems then we need to consider some further possibilities like if cert support is built into your version of taskwarrior.

Let me know how it goes.

Apparently, the files are not readable

I changed their permisions but it didn’t work also

What happens when you run:

$ cat $HOME/.wingtask_certs/dst.pem

Does it show this output?

-----BEGIN CERTIFICATE-----
MIIDSjCCAjKgAwIBAgIQRK+wgNajJ7qJMDmGLvhAazANBgkqhkiG9w0BAQUFADA/
MSQwIgYDVQQKExtEaWdpdGFsIFNpZ25hdHVyZSBUcnVzdCBDby4xFzAVBgNVBAMT
DkRTVCBSb290IENBIFgzMB4XDTAwMDkzMDIxMTIxOVoXDTIxMDkzMDE0MDExNVow
PzEkMCIGA1UEChMbRGlnaXRhbCBTaWduYXR1cmUgVHJ1c3QgQ28uMRcwFQYDVQQD
Ew5EU1QgUm9vdCBDQSBYMzCCASIwDQYJKoZIhvcNAQEBBQADggEPADCCAQoCggEB
AN+v6ZdQCINXtMxiZfaQguzH0yxrMMpb7NnDfcdAwRgUi+DoM3ZJKuM/IUmTrE4O
rz5Iy2Xu/NMhD2XSKtkyj4zl93ewEnu1lcCJo6m67XMuegwGMoOifooUMM0RoOEq
OLl5CjH9UL2AZd+3UWODyOKIYepLYYHsUmu5ouJLGiifSKOeDNoJjj4XLh7dIN9b
xiqKqy69cK3FCxolkHRyxXtqqzTWMIn/5WgTe1QLyNau7Fqckh49ZLOMxt+/yUFw
7BZy1SbsOFU5Q9D8/RhcQPGX69Wam40dutolucbY38EVAjqr2m7xPi71XAicPNaD
aeQQmxkqtilX4+U9m5/wAl0CAwEAAaNCMEAwDwYDVR0TAQH/BAUwAwEB/zAOBgNV
HQ8BAf8EBAMCAQYwHQYDVR0OBBYEFMSnsaR7LHH62+FLkHX/xBVghYkQMA0GCSqG
SIb3DQEBBQUAA4IBAQCjGiybFwBcqR7uKGY3Or+Dxz9LwwmglSBd49lZRNI+DT69
ikugdB/OEIKcdBodfpga3csTS7MgROSR6cz8faXbauX+5v3gTt23ADq1cEmv8uXr
AvHRAosZy5Q6XkjEGB5YGV8eAlrwDPGxrancWYaLbumR9YbK+rlmM6pZW87ipxZz
R8srzJmwN0jP41ZL9c8PDHIyh8bwRLtTcm1D9SZImlJnt1ir/md2cXjbDaJWFBM5
JDGFoqgCWjBH4d1QB7wCCZAA62RjYJsWvIjJEubSfZGL+T0yjWW06XyxV3bqxbYo
Ob8VZRzI9neWagqNdwvYkQsEjgfbKbYK7p2CNTUQ
-----END CERTIFICATE-----

If you did not get that output try:

echo $HOME

Is it possible your $HOME environment variable is not set? I suggest to edit your .taskrc and replace $HOME with the full path to your .wingtask_certs dir

What task diagnostics is saying is that it can’t read your cert files. Your permissions on the files are 777 so it’s not a perms or ownership issue. The last thing to check is if the paths are correct and maybe your $HOME var is not set? Here’s how to check

$ echo $HOME

If doesn’t return anything and you don’t see something like ‘/home/renan’ (it may not be this exactly, but as long as it’s not blank)

I tried to think about some scenarios where things might go wrong on our end:

  1. The wingtask_configuration.zip you downloaded contains empty or corrupt cert files. I checked your zip file and certs and found the certs were fine. I also downloaded your config locally, set up the certs and ran ‘task diagnostics’ and they returned ‘readable’
  2. Maybe the CA certificate is invalid. This was a distinct possibility and one I’m still open to exploring but the first step is that when you run ‘task diagnostics’ the status for the files must be ‘readable’ rather than ‘not readable’

TLDR: Check the paths to the cert files, check if your $HOME var is set, if it is not set go to your .taskrc and edit the config to use the full paths for the certs.

The $HOME var is set, but the sync worked with the full path of wingtask _cert files on the .taskrc

thanks

I was having the same problem and changing from the $HOME path to the full path fixed it. (my $HOME var is set, so I don’t understand what could have caused this…)

The forum was very helpful in this case.

Hey thanks renanCunha and corbintate for helping me figure this one out. I tried to make the configuration of sync between taskwarrior and WingTask taskserver as easy as possible because it’s kind of hard to do, I intentionally code the config to use $HOME because it makes the config more general across different users, it didn’t occur to me that the .taskrc won’t convert $HOME to it’s full path. I guess I’ll have to go back to the drawing on board on that on.